Ford Focus Forum banner

61 - 75 of 75 Posts

·
Registered
Joined
·
1,006 Posts
Here's one of under the hood.
The clicking sound is valves snapping against the head since they're 61# springs with stock cams. It's all it can be since timing is perfect and tappets are all within factory spec.
https://vimeo.com/142832694


Sent from my iPhone using Tapatalk
Great to hear you're getting everything worked out. My valves were also noticeably louder after I installed stronger valve springs.
 

·
Registered
Joined
·
56 Posts
Discussion Starter #64
Well time for an update. I put the car into storage. But before winter I plan to have the trans pulled again to remove the clutch since I'm having release problems. Even after pressure bleeding the clutch. I called Clutch Masters and they are going to refund me the cost of the clutch setup. I must say even though their clutch setup hasn't worked well for me their customer service has been top notch. They're very easy to deal with.

Going forward I'm switching to the Exedy hypresingle. Since I got an awesome deal on a new used one from SR performance. Thanks again!!

I also plan to pressure test all the boost piping to test of leaks. I'll take photos and post of how I plan to do that.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
56 Posts
Discussion Starter #65
So next week ill be pulling the trans and replacing the clutch. Also look into the the 2nd gear shifting issue. Talking to Terry Haines, he seems to thinks its either a shift tower issue or misalignment with the shifter cables. Stay tuned.
 

·
Registered
Joined
·
4,766 Posts
So next week ill be pulling the trans and replacing the clutch. Also look into the the 2nd gear shifting issue. Talking to Terry Haines, he seems to thinks its either a shift tower issue or misalignment with the shifter cables. Stay tuned.
Hopefully you have better luck with the hypersingle. If you need a transmission, let me know since I'm selling mine with a FRPP torsen diff and 4.06 gear.
 

·
Registered
Joined
·
56 Posts
Discussion Starter #68 (Edited)
Well I got the clutch installed along with new shifter cables. It shifts and disengages/engages great. Couldn't really drive it on the highway with it be winter. So the true test will be this spring. Old clutch seemed to be out of balance since less vibration was noticed, I also think my biggest problems was a faulty slave cylinder from CM. But I'm glad I went with the Hyper-single. Rather than risk taking the clutch out again.


While looking at the Clutch Masters FX-250 that I removed. I noticed the the spring hub on the clutch disk was rubbing against the pressure plate.

Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
56 Posts
Discussion Starter #72
Well went to the dyno. Put down 270whp @6892RPM and 265ft-lbs @ 3832RPM. All looked pretty good. Just proves the turbine wheel and housing is to small causing an increased pressure ratio. At some point 2871R here we come.
https://vimeo.com/191332048

Sent from my iPhone using Tapatalk
 
61 - 75 of 75 Posts
Top