Ford Focus Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
149 Posts
Discussion Starter #1
My Superchip for Computer code JFA8 was just installed, and the contacts WERE CLEAN. The engine didn't seem to perform a whole lot different, yet I did notice that in reverse the car chugged, not like usual. I pulled the chip, and cleaned the contacts again, and double checked the connection. Then I took the car for a test drive. I hit the speed governor @ 107 or 108, (which is nearly 30 mph premature for the chip) and pulled into my street like 15 or 20 mph and then the gauges dropped, the engine died, and oil lamp came on ??? I couldn't get it to start. I pulled the chip and finally it started again, what is the deal ??? I don't know what to do ? Any help would be appreciatted. I called Superchips, and they said they would be more than happy to look at it, and upgrade the program, but I can't find my receipt, and they need it !!!! PLS HELP !!!!

[ 02-24-2003, 04:49 PM: Message edited by: furiousfocuz2G ]
 

·
Registered
Joined
·
799 Posts
If you purchased from us, we will be more than happy to fax a copy of your reciept to Superchips. If you purchased from us, we will be more than happy to exchange the module. I answer because you e-mailed us for an answer and asked for me to look at your post here.
DT
 

·
Registered
Joined
·
149 Posts
Discussion Starter #3
thanx man emailed U back........Peace....
 

·
Registered
Joined
·
729 Posts
i had the same problem with my superchip. I figured out that the car kept diing everytime the made any type of movement. I roled up some tape, and placed them under two sides, then I taped down the chip really tight. No problems since. Been about 6 months!!!
 

·
Registered
Joined
·
729 Posts
I got a question for Cajun. Its seems from the posts that you're the guy to talk to about chips. I need many mods burned on it, but the most important is a higher idle and rpm limiter no sooner than 8000. I was told that superchips couldn't do that? Is that true?
 
1 - 8 of 8 Posts
Top