Ford Focus Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,586 Posts
Discussion Starter #1
SCT fixed it and sent it back and now after about 8 times of use it seems to have lost the ability to work with the advantage program again, this time so far the live update still reads it but last time it lost all usb connection
 

·
Registered
Joined
·
1,586 Posts
Discussion Starter #3
earlier in the day it did but it finally stopped being read again on both the PC and laptop, it s like the usb is shorting out on the xcal2
 

·
Registered
Joined
·
934 Posts
Iam not sure if this will help, but I talked to David at SCT customer support about this problem.

He told me that some of the earlier units did have a problem with the USB connection shorting out.

He said that I could sent it back if it keeps happening. Or that if I felt brave I could open it up VERY CARFULLY and see if anything is touching the USB connection.

Since I’ve already had to send one xcal2 back. I thought that the second choice was probably the best course to take.

I read that someone else did it in SCT forums but mine has since corrected its self. I haven’t really had a problem with it unless, I try to data log on another car.

I know that its not fixed and my xcal2 won’t work unless I have it plugged in all the time. If I try to do anything with it unplugged from the USB port it just locks up and tells me to check the connections.


I have not yet felt brave enough to try opening it.


Since it take so long to get it back.Ground shipping from Florida to Washington state takes about 10 to 12 days and they won’t send a new one until they get the bad one.


For now I can live with it. Only because my LC-1 will be here in a few days and I have to have it. Maybe after I adjust my fuel trims I’ll get the guts to open it.
 

·
Registered
Joined
·
1,586 Posts
Discussion Starter #5
cool thanks, Ill shake it around some but not gonna open it, they put a void if opened sticker on it this last trip it made so as many problems as its had no way.

They didnt replace my "unit" /w a new one just fixed it.
 

·
Registered
Joined
·
934 Posts
Ok, today I had a little accident. I dropped my xcal2 and it popped open.

Cough- cough and what do you think I found?

Well the wires that go to the key pad had a little pin hole where it had been arching to the USB port. So I took some electrical tape about a half inch square and placed it on top of the USB port. Like David at SCT said, the hardest part was closing it up again.

The two tabs at the bottom go in first and then there is one clip next to the cable on the left side. The left side as it faces you and that was it. I was thinking that there had to be more to it than that, but there wasn’t.

I plugged it into the OBD-2 connector and for the first time the key pad worked without having too be plugged into the computer. Everything works now!! I didn’t get any error using live link and was able to setup and log fine.

So, Now that everything is working I need to make up a new list of excuses for my wife. Why am spending so much time playing with the software. LOL
 

·
Registered
Joined
·
1,586 Posts
Discussion Starter #8
yeah thats cool but Im not gonna drop mine since they fixed it once and now it says void if opened, I dont think their plan of how it functions as a usb device was well thought out or at least its strange the usb<->serial device and create a com port, maybe thats part of the problem is that internal design. its cool but so far hasnt held up for me:-(

Randy I sent an email to you from SCT about my Xcal2.
 
1 - 8 of 8 Posts
Top