Ford Focus Forum banner

1 - 10 of 10 Posts

·
Stoned Scorpion says, "GET OVER H.....OOhhh! Brown
Joined
·
11,972 Posts
Discussion Starter #1
Well i was driving home tonite from my girlfriends house and my check engine light came on. Yeah the car seems to be in perfect working order but when i stopped at a stop sign and shut it off and started it back up, the tach when up to about 3500 and went down gradually. It makes me so mad because this is the 3rd time this has happened!!! Any ideas on what it could be? I think it a throttle senor or something. Sorry to bitch but I needed let out some of my anger and had to write this.


p.s.- its a 2002 SVT so thats prat of the problem what up with that ive heard alot of things bad about 02's??????
 

·
Registered
Joined
·
10,601 Posts
Well some people have had problems with 02's and other haven't. You have to expect some problems for the first year of production. However I think you are right that it is something to do with the throttle or throttle body. It just may need to be cleaned
 

·
Stoned Scorpion says, "GET OVER H.....OOhhh! Brown
Joined
·
11,972 Posts
Discussion Starter #3
Im takin it to the dealer today. I am not a fan of messing with sensors and its under warranty too. So it will save me the aggrevation and get it fixed so why not?
 

·
Registered
Joined
·
96 Posts
Dunno about PA, but my dealer charged me $75 just to pull the code.....grrr....and it turns out it was what I thought it was, a bad O2 sensor. None of it would have been covered under warranty either, as they told me I hit something which busted the O2 sensor, so it was my fault. I am never going back to the dealer again.
 

·
Registered
Joined
·
10,601 Posts
Im takin it to the dealer today. I am not a fan of messing with sensors and its under warranty too. So it will save me the aggrevation and get it fixed so why not?
If it is under warranty then I wouldn't worry to much about it. I am sure they will take care of it!
 

·
Registered
Joined
·
883 Posts
was it your check engine light or your battery light? I was getting the same thing in my car, and i thought it was the check engine light, but it was accually the battery light. It all fixed when i got a tune.
 

·
Registered
Joined
·
2,637 Posts
sounds to me like a faulty throttle position sensor. i had similar problems, and that was the culprit. easy to change, and the sensor isn't that expensive either.
 

·
Stoned Scorpion says, "GET OVER H.....OOhhh! Brown
Joined
·
11,972 Posts
Discussion Starter #8
It was the engine light. Yesterday, i was driving it and the light just went off. I was like wtf????? It has to be that throttle body positioning sensor. Im gonna take it to the dealer anyway tho.
 

·
Registered
Joined
·
140 Posts
i got rid of mine because of a problem similar to that. the check engine light kept coming on. come to find out it was a broken braket that held the down pipe. it would rattle and cut through the o2 sensor's wires. anyways, got rid of it because ford refused to work on my car.
 

·
Registered
Joined
·
248 Posts
My throttle position sensor went out too and I encountered the same symptoms. Take it to autozone or something like that and have it scanned for free
 
1 - 10 of 10 Posts
Top