Ford Focus Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
281 Posts
Discussion Starter #1
I have a Jackson supercharger with a ford racing big boost kit, the only problem i have with this kit is my belt slips for about a 1/2 to a second when i start it up. I also noticed that when i have my A/C on full blast it will slip when im starting from a stop in first. I dont know, but this morning i think i heard/felt it slip just going up the drive way... What should i do to solve this problem, other than that this kit is flawless in my eyes. Just need some pointers on how to solve this problem if any at all...
 

·
Registered
Joined
·
11,368 Posts
Hello there Qbert. In a couple of years I would like to have a setup similar to yours. Have you had it dynoed yet?? They all seem to be in the 170/155 range. Here is a website for slippage http://tiger.towson.edu/~nander2/sq.htm or you can search around. There are plenty of posts about smaller belts (I have read that a gatorback belt will help with the BBK) and JRSC rerouting. Hope that helps.
 

·
Registered
Joined
·
281 Posts
Discussion Starter #3
SIgh, i dont know whether i have a new or old idler pulley set up, looking at mine from the top of my motor looks different but i cant tell, my idler bracket looks larger than LED's, i just cant tell for sure... So what belt size should i go with for the Ford Racing Big Boost kit pulley isnt that like 2.5"? Then should i route the belt the other way? Just want it to stop... LOL good stuff, have a kit for 2 days and something already goes wrong, this is gonna be real fun on down the road i think...
 
1 - 3 of 3 Posts
Top