Ford Focus Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
294 Posts
Discussion Starter · #1 ·
Well, i've got it on, but now i've got some complaints. The back joint is tight, but i can feel an exhuast leak out of it. That's not cool
I thought you guys said this was a good quality piece. I think my money would have been better spent elsewhere ($100 more for the HKS). Also this is just as loud as my friends borla down low, although above 4000 you cant hear the bosal. So its loud down low (where i didnt want) and leaks. So far thats two things i dont like. Maybe I just expect more than other people in here, becuase i've delt with really good company's like AEM, HKS, and Apexi my whole life.
 

·
Registered
Joined
·
658 Posts
Originally posted by ruggedman:
Well, i've got it on, but now i've got some complaints. The back joint is tight, but i can feel an exhuast leak out of it. That's not cool
I thought you guys said this was a good quality piece. I think my money would have been better spent elsewhere ($100 more for the HKS). Also this is just as loud as my friends borla down low, although above 4000 you cant hear the bosal. So its loud down low (where i didnt want) and leaks. So far thats two things i dont like. Maybe I just expect more than other people in here, becuase i've delt with really good company's like AEM, HKS, and Apexi my whole life.
<font size="2" face="Verdana, Arial">something must be wrong. at idle you cant hear mine a bit...at 3000 plus it sounds awesome. no leaks, everything is tight. i couldnt have spent my money better. mabie bandit can help you out. mabie you have a bad gasket or something

Dave
 

·
Registered
Joined
·
3,440 Posts
I've installed 2, 1 on a sedan and 1 on a ZX3, no problems at all and no leaks, check to see if the gasket is messed up.
 

·
Registered
Joined
·
2,333 Posts
If theres a leak thats not fault of the exhaust but of the installer..I would get rid of the gasket and use that RTV High Temp gasket stuff...I think its called RTV...that will make for a nice tight seal...Ive heard the bosal and it sounds real sissy under 3000RPM.. It might be because of the leak of it might be rattling on something..check all your connections again..
 

·
Banned
Joined
·
17,312 Posts
You've DEFINITELY done something wrong....
You say the rear joint is tight. That one IS the hardest to get to. I'll bet it's not tight, or you've cross-threaded something somehow.
 

·
Registered
Joined
·
294 Posts
Discussion Starter · #7 ·
I redid the entire install again yesterday and i'm getting the same leak still. I think its do to one of the bolts on that back flange not being completely tight...i dont know how i'm gonna get at it though to get it tighter than it is. The exhaust seems to fit fairly well for aftermarket, the hangers are flexed forward a little though. After a day with it i'm somewhat satisfied, as for the sound it's pretty much your standard fare as far as 4 cyls go. Nothing really to write home about, but better than stock i guess.
 

·
Registered
Joined
·
362 Posts
QUOTE]something must be wrong. at idle you cant hear mine a bit...at 3000 plus it sounds awesome. no leaks, everything is tight. i couldnt have spent my money better. mabie bandit can help you out. mabie you have a bad gasket or something

Dave[/QB][/QUOTE]

I agree with Dave. Give BANDIT a shout and see what he can do for you. Good Luck!

Kevin
 
1 - 9 of 9 Posts
Top