Ford Focus Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
222 Posts
Discussion Starter #1
on the way home from work on friday the car just died! unpluged battery let sit replugged it in started car idles like crap up/down black smoke out tail pipe, shut car off removed chip restart same thing, anyone know what is up?

have injen III CAI
Findanza cam gear
-2,0 (never changed)
jba shorty
pacesetter catback
superchip
fc 65mm tb
fc udp
 

·
Registered
Joined
·
1,543 Posts
take this to the tech thread , noresull might be able to help you!
 

·
Registered
Joined
·
1,287 Posts
yea ur fuel pumps shot...time for a new one
 

·
Registered
Joined
·
2,333 Posts
you sure you have good clean oil in the car? Or are you low?
 

·
Registered
Joined
·
1,287 Posts
idles like crap up/down black smoke ...just sayin sounds like fuel pump...dunno then...cause thats not normal
 

·
Registered
Joined
·
2,440 Posts
sounds like the maf to me

also, make sure that little safety fuel cut off button is pressed (its by where the passenger would put his right foot)

mine got activated somehow and my car died in the middle of the road, would start and then die....called the towtruck but relized it was that before the car got towed...
 

·
Registered
Joined
·
1,179 Posts
check that you have good spark!! check the wires going to the coil pack (thing that spark plug wires connect to), check plugs and the wires. that's the first thing i would start with...
 

·
Registered
Joined
·
944 Posts
I had a bad plug wire and it did kinda like you'd said. I'd check that out. I had ford racing ones at the time now i'm running the stock ones again though.
 
1 - 10 of 10 Posts
Top