Ford Focus Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Greetings,

So I'm trying to figure out why my car idles horrible, stalls, etc. I of course searched through this forum up and down. Took the advice given to others in my situation, checked the vac hoses, EGR, etc.
While I was checking out the EGR, I noticed a bolt with threads on it, unthreaded and laying on the elbow of the tube coming out of the bottom of the EGR. I wasn't sure if that was normal, so I pushed it back up the tube and threaded it into where it went, hand tightened (but it's still lose). Before I go and mess with that anymore, how is that supposed to be? Really tight? Hanging lose like it was? What the heck is that?


Thanks for the help.


-Z
 

·
Registered
Joined
·
122 Posts
I don't know if that is going to fix your problem but that would cause those symptoms you are having. That nut you are speaking of is supposed to be tight. That is the nut the attaches the egr tube from the exhaust to the bottum of the egr valve. There aren't any codes? No check engine light?

That would be something that would set a cel.

Tighten it and see if it doesn't fix your problem.
 

·
Registered
Joined
·
889 Posts
mine was like that also. Made my car sound funny when i accelerated, kinda like something was loose, and all it was, was that damn bolt rattling on the metal line. My car ran fine though, I don't think it really has anything to do with the way the egr works because mine was like that for a few months and my car ran great. Make sure you tighten it up as tight as you can, becuase about a week ago mine came out again.
 

·
Registered
Joined
·
122 Posts
Lock tight....

Or mabe jb weld if your not planning on removeing it any time soon...

 
1 - 4 of 4 Posts
Top