Ford Focus Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
i know "smacking something" is not the technical word for it but oh well. basically hard acceleration off the line i get a nice thud i'm pretty sure the mounts are fine. is there anyway to lock it down, maybe poly mounts or something
 

·
Registered
Joined
·
100 Posts
weell ball park guess would be a rod problem..if its a svt and u have the aem cold air intake..it could be what ive had happen..the intake tube wobbles up an down on the clutch line making noise in the pass compartment..if u got warranty id suggest taking it in for a professional opinon
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
to clarify the torque is causing the motor to twist on its mounts and then hit something(thud).it only happens when i drop the clutch and hammer it, normal driving is fine and the car is a 2003 zx3 2.3L
 

·
Banned
Joined
·
17,312 Posts
You need a Poly-U "Tranny-Mount" bushing set.
I have a prothane set.
There's one small problem, which I won't go into, but the NEW Re-designed Energy Suspension Bushings have fixed the only problem I've experienced w/ my Prothane kit.
Contact Tony D at NewEdgePerformance.com (You can find his link on the front page of Focaljet under the "Resources" link.
)
Tell him you want the Updated Energy Suspension Tranny-Mount bushings, and tell him I sent you.
That will totally Stop what you're describing.
 

·
Registered
Joined
·
19,264 Posts
you're right.... not gonna work for you.



Nobody has an engine mount system for the 2.3... so you'll have to live with it for now I guess....
 

·
Registered
Joined
·
17 Posts
Discussion Starter #8
you're right.... not gonna work for you.



Nobody has an engine mount system for the 2.3... so you'll have to live with it for now I guess....
well at least i know what it is!
 
1 - 8 of 8 Posts
Top