Ford Focus Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
281 Posts
Discussion Starter #1
Ok, i really dont know how to explain what happened but i have some possible ideas as to why i got a check engine... for the past two weeks or so in Missouris it's been VERY HOT and HUMID and i got my JRSC put on right in the middle of this weather, but last night i was driving around and the check engine light turned on, it's been very rainy and there has been a HUGE drop in temperatures, could the weather and temp. changes throw the ECU of, escpecially a reflashed one? Anyhow the car was driving PERFECT, no idol problems, boost fine, moves a lot better in the cooler less humid weather as well...So i take the car home check your average spark plug wires, maf... made sure everything was plugged up and ok, then i unplugged the battery for about 10 minutes, started the car and NO check engine? Again the car is running amazing no problems at all... My only other guess was an out O2 censor or something... Any idea? the car runs fine...
 

·
Registered
Joined
·
3,943 Posts
should have waited and had the code scanned first before erasing. just have to wait and see if it comes back on or not.
 

·
Registered
Joined
·
281 Posts
Discussion Starter #3
Figures, i thought about that, i mean it's not like i work a dealership or anything...O well if it comes back, ill have a Tech where i work run a Consult on it... Any other ideas?
 

·
Registered
Joined
·
2,572 Posts
No offense, but even TRYING to figure out whats wrong with it without pulling the codes is jsut a big wast of time for you and everyone else. That CEL could be 100 different things. Good lukc though,


Scott
 

·
I change diapers now
Joined
·
14,444 Posts
Definately shouldn't have got rid of it before you got it scanned.

Any local Autozone will scan it for free.

- Drew
 

·
Registered
Joined
·
281 Posts
Discussion Starter #6
Now i feel retarded
, probably messed something up.....
 

·
Registered
Joined
·
535 Posts
Now i feel retarded
, probably messed something up.....

I wouldn't worry too much just yet. If it's a hard fault it should come back within 12 miles or so. It's probably something like egr. I know I've had one of those. It was the same code as when I had a bad dpfe. It will come back if there is a real problem. Just don't erase it when it comes back.

Louie.
 

·
Registered
Joined
·
742 Posts
The autozone thing doesn't work anymore. At least it doesn't out here in cali. I had a similair thing happen with my car, engine light went on for no reason, unplugged battery to erase and it hasn't been back in the last 300 miles.
 

·
Registered
Joined
·
19,264 Posts
In cali... they can't scan it for you... but leave them your credit card and they'll letcha scan it in the parking lot.
 

·
Registered
Joined
·
2,572 Posts
The autozone thing doesn't work anymore. At least it doesn't out here in cali. I had a similair thing happen with my car, engine light went on for no reason, unplugged battery to erase and it hasn't been back in the last 300 miles.

A CEL doesnt come on for no reason. There is a fault of some sort that the PCM detects.

Scott
 

·
Registered
Joined
·
4,271 Posts
Depending on the scan tool, some codes don't show up. I had a code that the Predator couldn't see, but my Actron 2 did.
 

·
Registered
Joined
·
281 Posts
Discussion Starter #13
Ok, ive driven like 40 miles since it happened, and CEL hasn't came on yet, and again the car runs good... Umm, should i have a tech at the Nissan dealership i work at run a Consult on it anyway? What about advanced auto. do they do the scans? I dont have an autozone near me....
 

·
I change diapers now
Joined
·
14,444 Posts
Autozone is the only place that still does it for free.

- Drew
 
1 - 14 of 14 Posts
Top