Ford Focus Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
237 Posts
Discussion Starter #1
Shortly after I installed my FCTB I got a CEL. It was giving me a trouble code for the IAC valve. I reset the computer once and reinstalled the stock TB ran it for a week or so - no CEL. So I think everything is alright and I put the FCTB back on. I drove no further than 5 miles and the CEL comes back on. So Im fed up by this point and decide to reinstall the stocker and take it to Ford. They tell me the IAC is functioning fine, but their is a trouble code for the IAC valve. So they replace the valve and give it back to me - no CEL is on. About three days later I put the FCTB back on, because I love the way the car feels with it on, again the friggin' CEL comes on after about 50 miles of driving. What the heck is going on? I tried calling FC once before I took it to Ford and they had never heard of this before.

Nader, this TB is only a couple of months old it is still in perfect condition and I still have the receipt. Is there anything you guys can do for me?

Thanks

[ 11-23-2002, 10:11 AM: Message edited by: FOKC ]
 

·
Registered
Joined
·
110 Posts
That's a hard one....
 

·
Registered
Joined
·
1,012 Posts
give it a couple of weeks can you wont even notice the CEL.
mine been on forever now!
 

·
Registered
Joined
·
3,212 Posts
I would take a real close look for a vaccum leak at the intake manifold/TB connection. I have not bought one of these TBs simply because I think asking a paper gasket to seal against the plastic flange on the manifold is not the brightest of ideas.

[ 11-23-2002, 03:28 PM: Message edited by: Welding Rod ]
 

·
Registered
Joined
·
1,649 Posts
Originally posted by Welding Rod:
I would take a real close look for a vaccum leak at the intake manifold/TB connection. I have not bought one of these TBs simply because I think asking a paper gasket to seal against the plastic flange on the manifold is not the brightest of ideas.
<font size="2" face="Verdana, Arial">True.. are you using a silicone sealant along with the paper gasket man?
 

·
Registered
Joined
·
432 Posts
Originally posted by hotfocus:
give it a couple of weeks can you wont even notice the CEL.
mine been on forever now!
<font size="2" face="Verdana, Arial">
 

·
Registered
Joined
·
717 Posts
Originally posted by Welding Rod:
I think asking a paper gasket to seal against the plastic flange on the manifold is not the brightest of ideas.
<font size="2" face="Verdana, Arial">Nothing a bunch of RTV Silicone Gasket Maker won't fix!
 

·
Registered
Joined
·
3,212 Posts
It took decades for the OEMs to get their heads out and move quality standards foward with things like O-ringed connections.

Now you can "upgrade" to the aftermarket that will take you back to the nostalgic days of sealant and scraping gaskets.
 

·
Registered
Joined
·
5,580 Posts
some issues can arise when the idle screw was not set correctly and thus is causin ur car 2 idle 2 low and that will flip a cel.

-Ult
 

·
Registered
Joined
·
6,179 Posts
Originally posted by Welding Rod:
It took decades for the OEMs to get their heads out and move quality standards foward with things like O-ringed connections.

Now you can "upgrade" to the aftermarket that will take you back to the nostalgic days of sealant and scraping gaskets.
<font size="2" face="Verdana, Arial">Apparently you don't own a BMW! They still use paper gaskets for almost everything: throttle body, valve cover, water pump...

I agree. O-rings rock.
 
1 - 12 of 12 Posts
Top