Ford Focus Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1 (Edited)
2002 Ford Focus

So I was going ti the gym and my car completely cut off started stuttering when I pressed the gas so I fixed that problem it was the fuel pump so I replaced that and now it’s getting plenty of fuel it will crank but will not run I have replaced the spark plugs and the fuel module I have checked if the fuel rail was clogged but it’s not.

Could there be an electrical problem with the injectors? They aren’t clogged

Is there a relay or a fuse for the injectors?
 

·
Registered
Joined
·
2,441 Posts
I think in the black fuse box under the hood on the drivers side is a fuel pump relay, I don't which one though. Also the inertia safety switch for the pump is behind the front passenger floor kick panel for another odd ball possibility.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I already checked the fuse I already checked the cutoff switch

It’s getting fuel but some how it’s not getting through injectors and there not clogged I just replaced my crank sensor
 

·
Registered
Joined
·
32 Posts
Are you getting dashes on your odometer when you turn the key on? If not you can read the DTCs, if so check the wires going to your power steering pressure sensor. If those wires short out against each other your car will be dead in the water with dashes on the odometer. Just unplugging the sensor doesn't kill the car or fix the situation. My bad spot was hiding under a zip tie, wires melted together and shorted there. Took me months of looking over and trying everything to find it...
 
1 - 6 of 6 Posts
Top