Ford Focus Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4,271 Posts
Discussion Starter #1
When I start getting to the higher rpm range my fuel pressure starts to drop off a bit, I *think* is gets down to the mid to upper twenties according to my Fuel pressure gauge.

What are you guys doing to compensate for it, as in bigger fuel pump, boost a pump, or what?
 

·
Dyno Queen
Joined
·
7,859 Posts
Just upgrading to bigger lines would probably be enough, but a boostapump is an easy install and probably wouldn't be a bad idea.
 

·
Registered
Joined
·
24,330 Posts
When I start getting to the higher rpm range my fuel pressure starts to drop off a bit, I *think* is gets down to the mid to upper twenties according to my Fuel pressure gauge.

What are you guys doing to compensate for it, as in bigger fuel pump, boost a pump, or what?
What injectors do you have? Twenties is NOT good at all. Do you have a data logger?
 

·
Registered
Joined
·
4,271 Posts
Discussion Starter #4
I'm running 50# injectors, yes a have a data logger. I know 20's isn't good but it only happens at WOT way up in the rpm range. Since this is going to be a daily driver I thought I would just play it safe.
 

·
Banned
Joined
·
1,109 Posts
no boost-a-pump is needed. just a little CFL secert. Hint check the voltage at the fuel pump, its no where near 12v.
 

·
Registered
Joined
·
2,572 Posts
the fuel pump is pwm. And I dont really like the boostapumps. THere is other actions that I would take before ever considering a boostadump.


Scott
 

·
Registered
Joined
·
4,271 Posts
Discussion Starter #9
Here's something I noticed today, I was playing around with the J&S to see if it was working right, which I'm not too sure about now.

Anyways, I was making acouple of WOT runs to check my AFR on my FJO and I look over at the fuel pressure gauge and it was hold pressure just fine, all the way from first to the end of 3rd. The only thing I can think of is when my intake was cracked the ECU was showing a +25% to my short term fuel #1, so maybe it was just running itself out of flow??? Trying to make up the difference?

Beats me, all I know is its holding fine now.
 
1 - 9 of 9 Posts
Top