Ford Focus Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
128 Posts
Discussion Starter #1
Well, I finally was able to bring the car back to have my alignmet looked at. Sure enough, left front went from -0.9 to -2.1. Right front stayed the same as where they left it the first time at -1.4. So, I take it back to get it looked at, and because it was pulling to the right. they set the LF to -1.8 and RF to -1.2 (not sure how that is going to help the pulling issue) and added a nice little extra. Every time I hit even a little bump, there is a loud clanking noise and the steering wheels jerks a bit. I took a quick look, but didn't see anything that looked too out of order, but it is night and my little maglight can only show me so much.

Any ideas as to what is causing the noise? I'm calling the shop up first thing in the morning to see about straightening everything out.

Oh, and to top it off, neither of my Gaz struts click anymore while trying to adjust them.

Mods are in the sig. I'm thinking I'm going to ask for my money back, so I can take the car to another shop. I really don't want to drive it now, as the clanking noise is extremely loud and I am really worried about it.

Thanks for any help....
 

·
Registered
Joined
·
34 Posts
Yup, definitely take it back. One time I had some brakes changed (back before I learned how to do it myself) at a Ford dealership, and afterward I had some serious rubbing issues; I think from them taking a mallet or something to my driver-side rotor to get it off; regardless, I took it back and made them fix it.
 

·
Registered
Joined
·
395 Posts
Weird, i had the spc plates and thought those were the cause of the clanking sound. I replaced them with Progress shims and it still makes that sound.

So, i dont think it's your SPC plates making that sound, but something else. I still can't find it to this day. I'm thinking it's brake related, because i need to do front and rear brakes badly. How are your brakes?

Good luck with this one. Let us know if you work it out.
 

·
Registered
Joined
·
128 Posts
Discussion Starter #5
I took the car back yesterday morning. Turns out, they had trouble getting the top strut nut tight, and gave me the car back with it still loose.


Anyways, everything has been tightened down now and the car is driving nicely once again. The driver's side still has a little more negative camber than the passenger side (reason I brought it there in the first place)
 

·
Banned
Joined
·
17,312 Posts
I took the car back yesterday morning. Turns out, they had trouble getting the top strut nut tight, and gave me the car back with it still loose.
That was MY guess. I've been there, Done that.
Mine has been made easier for future work w/ the addition of some washers as spacers so the nut isn't so far down in the cup on the upper strut mount.
 
1 - 6 of 6 Posts
Top