Ford Focus Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Have a 30 mile commute. Last week on the way home Focus stalled at about 60mph. Rather it started jerking roughly. I tried to apply more gas but the problem only worsened as the accelerator was pushed. I began to downshift but eventually the car died and I coasted to the median. After a few seconds I restarted and made my way home without further event.

Car is a 02 SPI with over 100k, so I assumed a bad fuel pump. Changed the pump with aftermarket from Auto Zone. Aftermarket pump, walbro, was not an exact replica of the oe part but I got it installed. Try to start the car with new pump and nothing. Car turns but no ignition.

So I figure it may be a bad pump. Fuse is fine and relay is fine. At the turn of the key I can hear the pump run for a few seconds. I disconected the line at the filter to see if it was pumping. It was, however it seemed very weak in flow. I believe that the new designed sock may be restricting flow because it is smashed against the outside wall of the bucket. And the outer sock that came with the new pump does not fit at all. I cleaned the old disc shaped outer filter and reused it.

The following weekend I try a different brand pump from Discount Auto. It is in an airtex box, but when I opened it, it was the same as the walbro I got from AutoZone. I put this pump in with the same results. I have tried turning the key multiple times to prime the system, but it doesn't seem to make a difference. When I disconnect the fuel lines at the tank/filter they don't seem to be under a great deal of pressure.

I have looked at the rail for a schrader port, but do not see one. Neighbor has an inline pressure guage. Will that give me an accurate reading if I place it in the filters spot?

Checked for spark using a screwdriver on one cylinder. I understand now that that was a no no. But I had spark on that cylinder.

What is next? Check fuel pressure..? Anything else common that would cause these symptoms such as a bad tps? Remember the car was running when I started repairs. I was able to start the car and pull it into the driveway from the street.

It is also my understanding that this is a returnless system and has no regulator. But does have a pressure sensor on the rail. Any ideas?
 

·
Ask me about my e-peen
Joined
·
707 Posts
In my wifes 02, that same exact problem ended up being bad grounds.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Tried pulling the filter this weekend and using an inline fuel pressure guage but the fitting I had was the wrong size and it just leaked. Pulled the fuel pressure sensor on the rail and no fuel present. Pulled a couple plugs all looked dry. The pump is running and fuel comes out when I disconnect the filter. But I have no fuel at the rail. Is it possible the hard line is clogged? Is a plugged line common? Would it exhibit the symptoms described above? Also is it possible that the pump is just having trouble priming the system? Any ideas?
 

·
Registered
Joined
·
11,255 Posts
Plugged lines shouldn't be that common, unless your fuel filter isn't doing its job or you have some debris between the fuel filter and rail.

Is any part of the fuel line crimped or damaged?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
As I mentioned the filter that was on the car was installed backwards. Car has 100k plus miles. Filter was not original, but I don't know the last time it was changed and I've had the car over a year. The line is a hard line so I don't think it is crimped, but I will check. I get gas through the flexible lines off the top of the tank and to the filter. After the filter they are hard lines all the way to the point where I disconnected up front. Cycled the key with the line disconnected and nothing came out. I would expect fuel to be gushing from the line...correct?
 

·
Registered
Joined
·
1,027 Posts
maybe u did something that tripped the interia switch?..as for the jerkingthen dying thing sound kinda like what happend when my coil wires cracked
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
checked the inertia switch. but if the inertia switch was tripped, the pump would not run. I can here the pump running when I cycle the key to the on position.
 

·
Registered
Joined
·
2 Posts
for those of us with the non metal rod fuel modules the airtex fuel pump will not work due to different pump design. the discharge of the fuel pump on the old style module is more centrally located. so when you install a pump designed for the metal rod module, the fuel pump will sit ****ed in the housing and not seal, due to the new pumps discharge being located more to the edge of the pump casing. this is why there is little flow before the filter and with the filter's resistance there will be little to no pressure at the fuel rail.

(note i know that this thread has been inactive for quite some time but i wanted to add this information for any one looking for answers as to why they may be having the same problem, after installing a new pump into a non metal rod fuel module.)
 

·
Registered
Joined
·
205 Posts
I just had this issue! My car was running fine then sputtered out hard and lost complete power. I was still able to keep the car moving but barely. I could floor it and it wouldn't do anything! Motor was clunkin so hard. It was the coil wires. The adapter plug clip was not holding and one of the wires came out. I got a new piece and extended the wires...just took some but connectors and spliced the wires, extended and Wa-la! Fixed. The wires were so short that they was alot of tension when I would turn that it eventually pulled a wire out. So now they are longer and there is no tension at all. Car runs fine and has more power.
 
1 - 9 of 9 Posts
Top