Ford Focus Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter #1
Car stumbles SOMETIMES when accelerating from a dig. No stumble at any other point in the RPM range... not noticeable anyway. But this mostly happens when the car is fully warmed up. Fuel pump has already been replaced by the dealer, and the stumble even happened the same day as the fuel pump swap.

Car has stalled on me twice as well during random coming-off-the-throttle events.

2000 SPI SE 5 spd.

Thanks!
 

·
Registered
Joined
·
46 Posts
I had the fuel injectors replaced on mine as well as the fuel pump. Both were recalls during the 2001 year. Check with your dealer to see if your car was part of the fuel injector recall. I had all that replaced along with the fuel filter. Changed my spark plugs as well. My car is still stumbling when i accelerate and when i have the air on. But no CEL. Other than that it runs fine. I am thinking it is the DPFE sensor. I am gonna replace that this week and see what happens.
 

·
Registered
Joined
·
837 Posts
I would recommend doing a workaround, sort of like a test to see if the DPFE is going out. There are three methods of choice you could use to test to see if its going out. Axon has provided these method at FOCUS HACKS

Simple follow this link and read-up. Hope everything works.
http://www.focushacks.com/index.php?modid=80
 

·
Not Special Enough
Joined
·
10,540 Posts
IMRC kickdown.

secondarys open about 3200rpm. supposed to kickdown when you floor it too. Transition is not very smooth and you can bog easily, especially when the engine is in warm up mode.

stalling is not normal though.
 

·
Registered
Joined
·
107 Posts
Discussion Starter #7
PROBLEM SOLVED!!!





Coil was totally cracked, absolutely everywhere you could think of. Water must have gotten in and frozen and eventually cracked it. I'm not sure why yesterday was the day that it chose to go completely ballistic, but I bought a new coil today, and $160+tax later, car runs FANTASTICALLY. It has NEVER been this responsive or powerful. I thought it was supposed to be that [censored], but now it feels like a brand new car. Couldn't be happier!
 

·
Registered
Joined
·
837 Posts
I have experianced similiar problems, maybe I should check my coil back. I was thinking its DPFE too, i replaced my Fuel Filter. But still does some sputtering. I hope its not the fuel pump.
 
1 - 8 of 8 Posts
Top