Ford Focus Forum banner
1 - 15 of 15 Posts

·
Registered
Joined
·
217 Posts
Discussion Starter · #1 ·
ok i have recently put in a centerforce clutch aluminum flywheel torson lsd and 4.06 gears....well the car feels way faster on the streets but i can't get off the line at the track i went from having consistent 2.3 60's to all over the place i think i have had one 2.3 but then missed 2nd gear other then that i have had anywere from 2.4's all the way up to 3.3 60's it ether bogs and almost dies when leaving the line or i get a couple feet of wheel hop then it bogs down around 2500 or so and then goes...so could anybody tell me were i should be launching at or anything...thanks in advanced oh and pritty soon i will be getting a NX kit were should i set my window switch to come on and were to go off...and make a note i am sporting a ford racing intake manifold
on and should i spray off the line or rig up a happy button and hit it in second gear??
 

·
Registered
Joined
·
217 Posts
Discussion Starter · #5 ·
Re: launching with my new tranny setup???

i have centerforce clutch aluminum flywheel torson lsd 4.06 gears fc underdrive pullies fc race header bosal flex pipe focus sport stealth exhaust fc tb aem short ram ford racing intake manifold fc short throw shifter and i will be installing a NX kit next week i will have to find the sime slips when i get off work but there not pretty...before the tranny stuff i ran a best of 15.5 and now after like 10 trips down the track the best i have done is a 16.2 but it the launch thats killing me
 

·
Registered
Joined
·
217 Posts
Discussion Starter · #7 ·
Re: launching with my new tranny setup???

well i have tryed launching at like 3k but got lots of wheel hop and spin(this was before the new tires) so i cut it down to around 2k to 2,500 and now it freaking hops some then bogs down...i did learn one thing don't rev at like 3k then dump the clutch...my damn car bout shut off it boged so hard
 

·
Registered
Joined
·
3,853 Posts
Re: launching with my new tranny setup???

this may or may not help or have anything to do but what kind a trap speeds are you seeing with your setup?

sorry if this looks like a hijack.
 

·
Registered
Joined
·
217 Posts
Discussion Starter · #9 ·
Re: launching with my new tranny setup???

in the past i was looking at i think around 86 to 87 i think i ran a fastest of 87.9 but right now i'm seeing freaking 84 and 85 mph...yeah i know that sucks...well i guess i just got to practice more till i get it down...and i will be installing my NX kit sunday and monday and will try to make it to the track ether wensday or friday for some more much needed practice
 

·
Registered
Joined
·
358 Posts
Re: launching with my new tranny setup???

Check your motor mounts it sounds like you may have a problem with them. As for your window switch set at 3700 for activation and 6700 for shut off. You don't want to bounce off the rev limiter while spraying, instant kaboom! You also do not want the no2 to come on earlier than 3500 most people set it at 4k. Also I have noticed the AEM short ram causes my car to bog, more so when it is hot out side. The problem with it is it sucks up all the hot air that builds up under the hood while you are sitting there at the staging line. Then you open the trottle pulling in the hot air which is less dense causing a momentary bog until you get some cooler air flowing in there.
 

·
Registered
Joined
·
4,197 Posts
Re: launching with my new tranny setup???

I would say try launching at about 4k but feather the clutch out and roll in that throttle...it takes some getting used to but I guarentee you will see better times.

Hell with 87 -88 mph traps that car should be running like a 15.2 or so
 

·
Registered
Joined
·
217 Posts
Discussion Starter · #12 ·
Re: launching with my new tranny setup???

yeah before the tranny mods my best was a 15.5 after only 2 runs
so anyways i recon i just need more practice oh and i will look at the motor mounts but i think there ok i also put in the tranny motor mount inserts. thanks for the replys
 

·
Registered
Joined
·
657 Posts
Re: launching with my new tranny setup???

window switch sucks, i no !!! wot breaks tires loose in 1st. an 2nd. the button is the better of the setups, that way you can control the spray. as for your launches, with the button youll want 5k revs, something you cant do with a win. switch. wot you can but youll get no traction... so go with the button and as for your bogg stay on the street till you get used to the clutch, that was my problem with same thing... have fun
 

·
Registered
Joined
·
657 Posts
Re: launching with my new tranny setup???

after 2nd. grabs then hold on for your life
if you want a clean install on a button then use your horn buttons for activation
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top