Ford Focus Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter #1
Well after going throught the entire car too c what kind of problem i was facing, i found that the dsi was broken (go figure right). But this time it wasnt the clip. The whole damn cable broke. So after two days of taking stuff off of the car and moving things around i was able to get the dsi control box off. After taking it apart i find that the cable that moves the clip has snaped in the middle not just at the clip. Now comes the fun part, trying to find the same cable and not go to ford and pay 20 or 30 $ for it. Sevral days pass and i finally fond one. I take the box apart and do some minior mods to the cable that i bought. Oh i only paid $1.99 for it. Reseal the dsi box, 2 part appoxy the cable to the front dsi clip, let dry, pull the car out of the shop and take for a test drive. Price of cable 1.99, price of 2 part appoxy 4.99, price of getting dirty and having the project work correctly PRICELESS. Just kidding. All in all the project was a success. I figure i saved about $100-300. If anyone has this problem let me know i would be more than happy to help u out. Peace out
 

·
Registered
Joined
·
105 Posts
Discussion Starter #3
the loss of the short or long runners ( not sure witch one is witch) was a drastic change. The car had no low end power. The dsi really does make a diffrance on performance and on gas mile age.
 

·
Registered
Joined
·
1,231 Posts
true that, when mine was broke for a while it almost felt b16ish, no power in low end then 5000 or so rpm's it wouold really wake up.
 

·
Registered
Joined
·
105 Posts
Discussion Starter #5
Thats about it, svo and i have very close hp and tq #s i had mine dynoed at 169 and 159 thats kind of funny
 

·
Registered
Joined
·
105 Posts
Discussion Starter #7
off road pipe, custome exaust (cant spell sorry) polly mont bushings, aem cai, focus central throttle body, steeda short throw, and that was also on 94 octane... even with that much power and tq i still couldnt manage to pull any faster than a 15.2 at milan drag way. Man i need to learn how to drive better
 

·
Formerly focus_wrc
Joined
·
7,422 Posts
i can see the cable move when i rev the engine after 5k the cable pull and release it when it goes below 5k so that mean mine is ok?
 

·
Registered
Joined
·
207 Posts
Yea, You should be able to see the clip/cable move at 5or 6 K. As long as it moves you should be good to go.
 

·
Registered
Joined
·
887 Posts
--> "So after two days of taking stuff off of the car and moving things around i was able to get the dsi control box off."

What???!! It takes an easy 20 minutes to get the "dsi control box" (IMRC accuator) off. Put the front wheels on blocks, turn the wheels to the left and go in under and behind the left wheelwell splash guard (two plastic screws out) and three nuts later and it's off. Don't know how you did it but for sure it was the hard way.

For sure the car is a no-torque dog when the runners are stuck in the open position and gas mileages does suck.

Glad you got it fixed though. Mine just broke at 41k miles and ordered it from one of the folks online here for $87 delivered.
 
1 - 10 of 10 Posts
Top