Ford Focus Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3,943 Posts
Discussion Starter · #1 ·
the cat was colapsed and laying in the bottom of the can blocking the exit hole. Put on new cat and it's all good for now. Race header should be here soon.



It seems to be that the cat is blocked so i ordered another one should be here tommorow. It so blocked that it blew off the dpfe sensor hose. Its being replaced under warranty but i need to get an offroad pipe or race header soon don't want to fry the new either.




well my just started acting funny yesterday morning, the rpm's would hang for a while then stop then come back. I had just washed the car that morning and took precautions to prevent water fom entering my scoops. Well after letting it sit for awhile that problem went away but the car has no power at all. I can barely keep it at a steady speed while on the highway while going up a hill or slight incline. If i floor it (WOT) it make noise like its sucking in air but does not go like it used to.


mods so far are:

FC 65mm tb
FC 3pc. under drive pulleys
Pro-M 70mm mass air meter
Ford Racing 24lb. injectors
Volant intake
Diablosport chip
Mac shorty header
Custom Flexpipe back dual exhaust

Also wondering if the diablosport chip will prevent any dtc from showing or lighting up the cel light, as i have now cel as of today.


thanks for any help you can offer.
 

·
Registered
Joined
·
5,446 Posts
Re: Major loss of power! Need help.

do you have a CEL? you might be in limp mode
 

·
Registered
Joined
·
3,943 Posts
Discussion Starter · #4 ·
Re: Major loss of power! Need help.

no cel's as of today and no rotten egg smell either. hooked it up to a ngs scanner today and fuel pressure at the fuel rail was 40lbs. is this normal? they didn't get time to look at it yet so hopefully tommorow.
 

·
Registered
Joined
·
3,943 Posts
Discussion Starter · #5 ·
Re: Major loss of power! Need help.

bump for update see original post.
 
1 - 5 of 5 Posts
Top