Ford Focus Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8,272 Posts
Discussion Starter #1
umm...is this possible? Not my tranny motor mount, but the part where it bolts to the tranny, just snapped i think, i didnt get a chance to get all the way under, but i can move my whole engine around, and my tranny mount is in tact

wtf? If its part of the cast piece of the tranny, how the hell do u fix that if its the actual shell of the tranny? How does this even happen? WTF WTF WTF is up with these cars...
 

·
Registered
Joined
·
1,608 Posts
DUDE, do not drive your car or this will happen. Thats a pic of a JBA Shorty header after only about an hour of driving with a broken mount.



Yes this is a result of FastFocusZX3 (R.I.P.
) driving with that same mount broken. Not the actual motor mount, but the bracket that bolted onto the transmission. His motor rocked back and forth so much it broke the header in half. This caused flames to shoot out the exhaust manifold and burn huge marks on the underside of his hood. I think he also broke some shifter cables, I dont remember too well, we cant ask him
 

·
Registered
Joined
·
122 Posts
My first trani busted the rear tourqe trani mount in half and I drove it home and it ripped the fitted vacuum line out of my intake and broke the intake. That was at 15k they fixed that under warrenty, then my trani lasted until 86k and I had to get a junk yard trani.

The second trani I got out of a junk yard already had the peice you are talking about busted. All I did was swap the bell houseing side of the original trani with the broken piece off of the new trani and it works fine.
 

·
Registered
Joined
·
2,538 Posts
well where the dog bone mounts to your tranny, that bracket is replacable, i had to replace mine when the bolt stripped out, 20 or 30 bux for the mount
 
1 - 6 of 6 Posts
Top