Ford Focus Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
180 Posts
Discussion Starter · #1 ·
ok i dunno what happened im thinking its an ignition problem but yesterday on the way home, my car was DEAD, the battarty light kept comming on, and it wouldnt rev right in neutral, i barely got it to rev to 6k, it had NO power almost and i had to wind it out in 2nd to get up to 40 and at WOT it wouldnt go any faster, it would surge and pick up speed for a second and then die again with no power. when i got home it finally stalled out. also, it seemed that sometimes for a few seconds it felt normal and i had normal power but mostly it would feel like its running on 2 or 3 cylinders. sad sad day, its at the dealership now im wondering what the problem is and hope to get it back soon.
 

·
Registered
Joined
·
643 Posts
Dead battery caused by a bad alternator or belt or bad battery... That caused all your no power problems.
 

·
Registered
Joined
·
1,574 Posts
Coilpack, this happened on my sedan a few months ago. Horrible stumble turned out to be from a faulty coilpack, and it literally felt like 2 cylinders and it sounded terrible.

Yeah, I could only go about 35-40 mph too
 

·
Registered
Joined
·
742 Posts
I just had some warantee stuff repaired and when the said here it is . I started to drive away and NO power.

It was the "Throttle position sensor" on the throttle body, all better now
 

·
INCREDIBLY SHRINKING POST COUNT!!! (PSST...Add 10K
Joined
·
6,259 Posts
So go buy a Honda and quit your whining!
I think he is looking for a reason why it is happening and looking for assistance I don't see him as "whining"
 

·
INCREDIBLY SHRINKING POST COUNT!!! (PSST...Add 10K
Joined
·
6,259 Posts
well the dealership said they are replacing the coil pack and the boot...whats a boot??
Thats great they found the cause of your problem
.
As far as "a boot" I have no idea but perhaps someone else will chime in and answer your question.
 
1 - 10 of 10 Posts
Top