Ford Focus Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
823 Posts
Discussion Starter #1
I just put my jba on about a month ago and shortly after that I noticed that I have an exhaust leak.. I retorqued and everuthing any help would be greatly appreciated.
 

·
Registered
Joined
·
256 Posts
If yours is like mine then you'll need to have the thing machined. The header tubes were not flush with the flanges and make it near impossible to get a good seal even with a good gasket. I couldn't reuse the stock metal gasket because the tube portruded so far. I haven't yet noticed any major leaks and the cost and time at this point isn't worth it for me to have it machined but I'm sure it will eventually. I kinda wish I'd gone with the FS one now.
 

·
Registered
Joined
·
823 Posts
Discussion Starter #4
yes I replaced the gasgets.. I figured out the problem and now it is running fine.. but it makes my car louder now and I can definetly feel the power.
 

·
Driver > Car
Joined
·
23,988 Posts
do you use stock ford gaskets for this? i've got a JBA header coming in
 

·
Registered
Joined
·
823 Posts
Discussion Starter #7
actually as far as the gaskets go. The jba domes with new ones and everything you need to replae it.. I t is just a pain in the arse to torque the bolts
 

·
Registered
Joined
·
256 Posts
The focus hacks instructions say to reuse the stock metal gasket if possible but I couldn't because the tubes weren't flush and the stock gasket wasn't big enought to make up for it. Kinda crappy if you ask me.
 
1 - 8 of 8 Posts
Top