Ford Focus Forum banner

Need big help with Dodge 3.0L starter - stuck at work

538 Views 8 Replies 5 Participants Last post by  Egz
My Dodge Dynasty won't turn over. I'm just getting a clicking noise when turning the key. I first suspected the battery, but attempts at jumping it aren't working. Plus, headlights come on at full strength. So, I'm working on a bum starter theory, and want to try to get it a wack or 2. But I can't find it.

Does anyone know where the starter would be on a 3.0l Chrysler engine would be?
1 - 9 of 9 Posts
Look under the front, a little to the left, kind of behind a support braket, attached to the trans. Before replace, check the connections!!
Found it, wacked it some, still no go.

Got more work ahead of me.
I have Chrysler FSMs from 86,88, and 90... Some of them include 3.0L info.. Let me know if you need any pages scanned.

Besides whacking the starter and the solenoid on the starter, try tapping the relay itself.. It is one of the silver cans near the battery and the computer.
See less See more
Well, tomorrow, I'm going to have AAA tow it to our hobby shop. (1 mile is kinda hard to push, with a lot of traffic around you).

I'm going to throw it up on the lift, get a better whack on the solenoid, and even try zapping it directly with the Focus's battery. I think I killed the battery making the clicking noise to troubleshoot it. Won't click anymore.
if you are still there, you may want to try and get the guys on base to give you a jump (there should be a help number in your local directory). My focus had the same problem you described, I even checked the headlights and they seemed at full strength. I let the car roll and then let the cluctch out, it came right to life. Serves me right for cleaning with the radio on. Good luck
Got a ride home. Tried jumping it twice, with 2 different cars. Same results.

Man, I wish it was a manual, like my Foci.
Could you possibly have a bad battery cable or 2? I know I had this problem on my Chevy truck where the battery was fine, but had issues when starting it. Replaced the cables and it worked great after that.
Got it working. It was that I had 100 dollars too much in my wallet.

It was the starter.
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.