Ford Focus Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
I just got a vibrant intake tube and filter. Problem is when i installed it the car stumbed, and ran bad. Thought it was because I disconnected the battery. So I ran it and it backfired under the hood and the check engine light came on
. It only ran good when it was in the high rpm range. Went straight home and checked for leaks. none..
I replaced it back to the hot box. Ran fine. Switched back to CAI and ran bad again. Does anyone know what's going on.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #3
I checked all the connections and they are as tight as possible. I did tap on the MAFS and it ran good for like 30 sec. then back to not so good. I am not using the MAF housing, just the plug-in sensor. Does that matter?
 

·
Registered
Joined
·
19,264 Posts
well... I'm gonna say yah use the right MAF setup. That sounds like your problem
 

·
Registered
Joined
·
427 Posts
The diameter of the maf housing needs to be very close to the stock diameter. If the new maf housing is larger it will cause incorrect air flow readings to the ECU. Your engine will run poorly.
 

·
Registered
Joined
·
234 Posts
Could it be excess filter "liquid/charger" getting sucked on the MAFS. But I don't know if that would cause it to back fire.
 

·
Registered
Joined
·
427 Posts
I believe all mafs are calibrated for a certain diameter housing. If you got a different mafs it would need to be calibrated to your tube diameter. Your idea of using the stock sensor housing should work fine. another option would be the pro flow 70mm assembly.
 

·
Registered
Joined
·
35 Posts
Discussion Starter #11
The sensor is in correctly. And not leaking around it. Would I be able to go with a bigger MAFS to correct the problem. Or just cut the intake tube and fit the sensor and housing. I thought that Vibrant was a good company?
 

·
Registered
Joined
·
35 Posts
Discussion Starter #12
Vibrant has made a recall on the intake tube on 03/06/2003 @ 10:00 am.
I am told their is a new intake tube that is not out yet that they want to send me.
I told them if it is not out to the general public that I would make a special trip up to the factory for the part and to have it tested on my car their and have a tour of the factory. Was told their shouldn't be a problem with that and right now I am just waiting for the call back. It is a drive from PA to Canada, but I want them to know I am very interrested in their products. Am I nuts........ I think not, just means a possible connection.
 
1 - 12 of 12 Posts
Top