Ford Focus Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
i just installed the demon coil and forgot to plug the MAF sensor (I unplugged it to unscrew the stock coil out) back in B4 going for a spin.
engine sounded horrible!! Knocking, stalling, coughing, wheezing...
I stopped and plugged it in but the checkengine light will not go off!!!! I unplugged the bat to reset the comp, but it's still on!!!!!!!HELP!!!
I dont think i damaged the engine but the light really freaks me out! AAAAHHHHHHHHHH!!!!

help me 'jet!
another ?...
i haven't opened the plug gap yet, will it overheat the plug?
I have to replace the plugs soon, so...
Autolite Dbl-plat or Denso Iridium?

HELP! NOW!
thanx 'jet!
 

·
Registered
Joined
·
2,538 Posts
when u tried reseting the computer how did u do it

take of the positive cable hit and let it sit for like 5 minutes?

if you did it right and your gauges went crazy you should be cool
 

·
Banned
Joined
·
17,312 Posts
He MAY have other issues.
(I'm surprised it ran w/ the sensor unplugged!!!)
I'd PM Noresull. (The Moderator of the Team Tech Forum)

Good Luck.


[ 11-29-2002, 02:46 AM: Message edited by: MichaelXi ]
 

·
Registered
Joined
·
2,333 Posts
disconnect your negative..same efect just much much more safer!I would do it for about 30-45 mins just to be extra extra sure
 

·
Registered
Joined
·
401 Posts
Unplug the positive battery cable and let it sit for about 30 minutes. Then tap on thebrake pedal a few times to totally discharge the system and try again.
 

·
Registered
Joined
·
2,226 Posts
You didn't plug the MAF back in while the car was on did you?


To reset the ECU much quicker, disconnect the Pos. terminal, then turn the headlights on. After about 2 min. you should be good....
 

·
Banned
Joined
·
17,312 Posts
Either way, regardless of resetting, if none of those work, PM Noresull about any other possible problems.
 

·
Registered
Joined
·
170 Posts
If the MAF is not pluged in right then you have that sounds from your engine.You didn't destroy anything.It is just the ECU drive crazy and it doesn't know what to do.Reset makes sure everything is pluged right and good to go.
 
1 - 9 of 9 Posts
Top