Ford Focus Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1,426 Posts
Discussion Starter #1
I'm having trouble with my charge tube popping off going into the tb. I'm also using t-clamps to secure everything together. It only happens when I give it 30-60% throttle cruising around. Boost gauge shows around 1-2lbs. of boost when it happens. Now here's the thing. Under WOT situations (4-5lbs boost) the charge tube never comes apart. If I'm cruising around and even gently stab the throttle then hold it at that position, POP GOES THE TUBE. Because of this, I know the engine isn't pulling at the tube. The car "feels" like the tube is filling up with air but the engine doesn't need to use it yet and the tube "backs up". Now of course when it's floored, the engine says "hmmm I'll take ALL that!"

I have a t3 blow-thru fmic setup using 2.5in pipe and a god aweful loud Turbo XS bov. When I shift of course, the bov works to relieve the pressure..so they say 2 blocks away
. I know it works.

Is it possible for air to get backed up like this? Anybody ever run into this problem?
 

·
Registered
Joined
·
5,141 Posts
u can spot weld a dot on 3 sides of the piping about a half end " from the end this is what some tuners do this it will help hold it on worked for mine
 

·
Registered
Joined
·
4,271 Posts
The only bead roll on mine is where it goes into the TB, I just tighten the crap out of the hose clamps. They hold just fine at 15psi
 

·
Registered
Joined
·
1,188 Posts
Air will build up before the TB. If the TB isnt open you will see ALOT of pressure before it, even though your manifold is seeing 1-2PSI. Your only letting a small amount of air that is available into the manifold. when you have the TB open all the way, the pressure behind the TB isnt as great.
 

·
Registered
Joined
·
990 Posts
Make sure the bov is venting easily. Take out a washer or two if you have to. It's cool as long as it's not leaking boost. Also, check for oil inside the pipes, this might be lubricating the silicone and allowing it to slip off.
 

·
Registered
Joined
·
6,553 Posts
Just curious mutt but is your boost gauge line hooked up before or after the tb?
 

·
Registered
Joined
·
1,426 Posts
Discussion Starter #9
Just curious mutt but is your boost gauge line hooked up before or after the tb?

After. Here is a pic of the line I tapped into:


After much thinking Gig, I think I'm going to put my spare stock-virgin IMRC spacer back in. Do you think with that big open port trying to shoot down 2 smaller ports at once is making the air "back up" and get turbulant?

And for my BOV, all the washers are out of it. So it's as loose as it gets.

To ponder...
 

·
Registered
Joined
·
6,553 Posts
I don't think that imrc would really matter really muttlee since it's after the tb but it would be cool to try just to see how it affects spool and power!


Is your bov vac line hooked up to the same tee or somewhere else?

When you screw the clamps down on the tb and the intake tube have you tried physically trying to pull them apart and wiggling the conection at the same time to make sure your clamps aren't oversize and not tightening down enough?
 

·
Registered
Joined
·
1,426 Posts
Discussion Starter #12
The bov and wastegate signal line is tee'd off from one of the plastic lines leading to the canister purge valve.


I'm gonna try to cut the charge pipe somewhere and put in a hump hose to let it flex somemore. sigh...more customizing
 

·
Registered
Joined
·
1,426 Posts
Discussion Starter #14
I'm gonna have to join the hair club when I'm all done.
 
1 - 14 of 14 Posts
Top