Ford Focus Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
3,212 Posts
Discussion Starter #1
I installed an Auto Meter Pro Comp boost gauge a couple days ago, replacing my old 2 1/16" Westach gauge that came with my old Aerocharger kit.

The Auto Meter is 2 5/8", oil filled, 20 PSI max, and mounted in a nice pod that clamps around my 1.5" roll cage tube.

Conclusion is liquid filled guages kick ass big time, the movement is way smooth and sharp hits on bumps don't cause the needle to jump or vibrate. Second conclusion is 2 5/8" gauges kick ass big time, at least for middle aged guys with middle aged eyes. Third conclusion is that the cage /pod mounting method allows you to put the gauge where it is real easy to see.

While I was at it I took off my Safeguard monitor, sanded the little ledge off from around its face so the entire OD is 2 1/16", then remounted it in another Autometer roll bar clamp on pod. Without the ledge I was able to slide the gauge back an inch or so inside the pod so the LEDs are shielded from direct sun light - similar to a shift light. Again I was able to put that bad boy right in my line of sight. Awesome. Sometimes the little things make a big differenece.
 

·
I change diapers now
Joined
·
14,444 Posts
Rod, I demand pics.

- Drew
 

·
Registered
Joined
·
5,141 Posts
i have the auto meter digi boost gauge has a small box under the hood it moves fast and smooth aswell it has peak hold and a warning light i love it
 

·
Registered
Joined
·
1,426 Posts
Hey can you help me out? I have the autometer phantom a/f gauge. Only the 1st two leds (lean) will light up. I know it's running rich cause I put 39# injectors with no tune in and now my town doesn't have to spray for bugs this year!
So I put the stock injectors back in and the meter is still only showing 2 sometimes flickering 3 lights (lean). I hooked the "violet" trigger wire to the 1st o2 sensor "gray" wire. Is that right?
 

·
Registered
Joined
·
19,264 Posts
Hey can you help me out? I have the autometer phantom boost gauge. Only the 1st two leds (lean) will light up. I know it's running rich cause I put 39# injectors with no tune in and now my town doesn't have to spray for bugs this year!
So I put the stock injectors back in and the meter is still only showing 2 sometimes flickering 3 lights (lean). I hooked the "violet" trigger wire to the 1st o2 sensor "gray" wire. Is that right?
You mean the A/F gauge?
 

·
Registered
Joined
·
1,426 Posts
Hey can you help me out? I have the autometer phantom boost gauge. Only the 1st two leds (lean) will light up. I know it's running rich cause I put 39# injectors with no tune in and now my town doesn't have to spray for bugs this year!
So I put the stock injectors back in and the meter is still only showing 2 sometimes flickering 3 lights (lean). I hooked the "violet" trigger wire to the 1st o2 sensor "gray" wire. Is that right?
You mean the A/F gauge?
Aww poop. haha yeah that one.
 

·
Registered
Joined
·
5,141 Posts
sorry it was 125$ for the digi auto meter
 

·
Registered
Joined
·
5,141 Posts
nice pics rod is it loud riding in your car i see u have a foam sound deading thing on the roof
 

·
Registered
Joined
·
5,141 Posts
oh rod i see u are getting the AEM AFR meter i have one there are very cool there is two wires u can hook to a 9 pin plug to date log with just Windows i can take pics if u want
 

·
Registered
Joined
·
3,212 Posts
Discussion Starter #16
Thanks. No it isn't too loud, at least anymore. It was pretty unbearable at first, especially in the rain when the drops hit the roof at speed. But I put in about 25 pounds of "Brown Bread", then the acoustic foam. I had removed all the factory tar paper when I built the cage 4 years ago.

The Brown Bread (not really Brown Bread, but made by the same company I think) cut the sound alot. The foam helps a fair amount too, but was mostly installed for appearance sake.

I plan to do some more finish interior work this summer and will post more pics as the various summer projects progress.
 

·
Krunktronik Tuner Goblin
Joined
·
3,346 Posts
Cage looks great. I'm getting lots of ideas.

Those cage mountable pods are made by AutoMeter correct?

Do the backs of your Forza's have any side to side flex?
 

·
Registered
Joined
·
3,212 Posts
Discussion Starter #18
Thanks. If I were doing it over again, I would set the main hoop back another 4 or so. I put it where I did because in the 2001 SCCA Performance Rally rule book it required the hoop to be "within 9 inches (IIRCC) of the driver's head when in the normal seated position"... so I put it farther forward. Then in the 2003 book the rules changed and a diagnol bar within the main hoop became required. Because I placed the main hoop a bit farter forward, the back of the seats now would interfere with installing a bar like that.... great. One of the reasons I lost interest.

Yes, the pods are made by Autometer. The gauge cup portion is molded rather poorly... or at least not cleaned up before packaging. I spent a fair amount of time with an exacto knife and dremel tool removing mold lines, extra material, and so forth. The good thing was the areas that mattered dimensionally were all done very well.

The Forzas are pretty rigid. I have never noticed any flex. But their brackets suck. The are heavy as hell and look like they were manufactured in a soviet block country, in 1980. The sliders are flimsy crap. And they held my drivers seat at an angle to the centerline of the car... it was rediculous. I basically cut them apart, salvaged a few of the old pieces, and made new ones.
 

·
Krunktronik Tuner Goblin
Joined
·
3,346 Posts
Wow, looks like I'm experiencing total oposite of you.

My Corbeau brackets are very nice, but the FX1's flex like crazy. I only weigh 150 lbs too.
 
1 - 19 of 19 Posts
Top