Ford Focus Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
386 Posts
Discussion Starter · #1 ·
i just installed a proform shiftlight into terminal number 48 on the ecm, and used to 15A defrost fuse on the lower left of the fuse bank, sometimes when i am ideling or just crusin the light will flicker. do you think it is my connection with the ecm, i dont, or do you think its my power or the light itself?
pleae help me, also if anyone gets one of these, make sure you dont point it at yer eyes at night cuz when it goes on its bright as all and you want to shift as fast as you can to get it back off hehe
 

·
Registered
Joined
·
406 Posts
I have one also. Mine only did it when the car was off ( the light flashing). So I just put a inline switch on the power wire. I also used a ford tach driver. Now no matter what it turns on around 5,500 RPM even if it is set at 8,000. Anyone one have a idea for that? I am starting to think I should have got another brand and the pills that go in it.
 

·
Registered
Joined
·
386 Posts
Discussion Starter · #3 ·
i'd like to give a little product review for this light, if you get it, get it for the drag strip and for looks cuz it blinds you when it comes on, so you will have to have it off at night hehe. anywauys the light still flashes at idle somtimes, any other ideas?
 

·
Registered
Joined
·
3,248 Posts
I had a Proform light on my car for a while and loved it, but replaced it with an aftermarket tach w/shlft light (for tach accuracy). If your having flickering it could be either the wire in pin 48 isn't up there tight enough, or your ground wire is loose. On mine I found it to be the ground wire.
 

·
Registered
Joined
·
66 Posts
i want to buy one of these. i will probably only set it really high so it will only come on when im racing. if the light is that bright maybe you should try nightshades on the light, or testor spray. maybe even a small peice of tint to go over it. i havent seen these in person so i dont know what it really looks like up close. also, how do you attach it to the ecu? do you splice it in the wire, or does it actually connect to the ecu? thanks!
 

·
Registered
Joined
·
386 Posts
Discussion Starter · #7 ·
the flickering comes on when i am coming down to idle, usually to a stop sign, i dont c how it can be the ecu connection cuz the light comes on at the rpm i set it to
 

·
Registered
Joined
·
2,572 Posts
The focus ECM doesnt use a "conventional tach signal"
The only way your going to get it to read accuratly at low RPMs is with a tach adapter. I have an autometer silverface tach w/shift light in my car. When I bought it I had to send it off to Autometer and they supposedly upgraded it to work with a DIS. When I got the tach back it worked but under 2000 rpm it would not read accuratly.
 

·
Registered
Joined
·
98 Posts
I've got the same problem with my Proform flickering at idle. I used an Autometer tach adapter and have double checked the ground wire, but it still does it. At least it comes on at the right rpm, 6300. Though I had to put a piece of tape on the dial because it vibrates itself to a lower setting. I'm thinking about switching to the Autometer mini-light with the pill kit. Anyone want to buy a used Proform?
 

·
Registered
Joined
·
386 Posts
Discussion Starter · #10 ·
i think my dial is getting loose also, this is a shift light thats definatly only for the track, no doubt about it.
 
1 - 10 of 10 Posts
Top