Ford Focus Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
i just recently installed an armor coated pacesetter shorty and it feels great. my question to anybody who might have the same problem, there is a clicking noise. you can only hear it when you are on the gas. the same thing happened to a fellow foci and didn't find out what the problem was. any information would help. thanks!

-eric


[ 03-06-2003, 01:44 PM: Message edited by: totallyfocused77 ]
 

·
Registered
Joined
·
83 Posts
It sounds like a exaust leak. The problem with the pacesetter header is that the flange that mounts to the head is not flat it has rings around the exaust ports that stick up off the header and dont allow the header to fit and seal properly against the gasket and the head. I have had that header on and off twice trying to get it to seal properly with no luck. Even if you get it to stop making noise you will still get the smell of exaust fumes on ocasion. This header gets a big thumbs down for fit.
 

·
Registered
Joined
·
4,125 Posts
the JBA has the same exact things regarding the flag. and no problem here. So I doubt that's the problem, since jba probably knows what they are doing since it is their 3rd gen. header I have. Ollie
 

·
Registered
Joined
·
473 Posts
i've had the non-coated pacesetter on my car for almost 2 years now, and the fit is not the best. i recommend buying a mr. gasket gasket and modify it to fit over the opening at least. works great. i've even taken it apart about 4 times because i had an off road pipe and a Random Tech high flow cat. no problems as of now. just get a gasket to help the fit! good luck!
 
1 - 4 of 4 Posts
Top