Ford Focus Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I hope this post is somewhat on topic. I am the proud owner of a 2000 Focus. I bought it new and it's been great. Driven it coast to coast. I just turned over 75 thou and now it's running poorly. It acts like at low rpm under load while accelerating, it cuts out. Kind of like someone is flicking the on/off switch. If I back off the gas it'll smooth out or if I down shift and get on it, it'll smooth out. Is this a problem that someone has had and already figured out? I'm guessing something fuel related, but it's just a guess.
 

·
Not so Photo Master
Joined
·
6,625 Posts
Please do not use "sick" in a negative way. Sick now means incredible, unbelievable, and so good it's nauseating.

thanks,
sicko


yeah, that sounds fuel pump/filter related.


and just so you know, these kind of questions can go here:
http://www.focaljet.com/ubbthreads/postlist.php?Cat=0&Board=UBB28

don't worry, one of the mods will move it to the right place
 

·
Formerly focus_wrc
Joined
·
7,422 Posts
Did u take your car for recall that ford had on focus? you might be able to do it for free.
 

·
Registered
Joined
·
46 Posts
Ive been told it is a DPFE/EGR sensor deal by many here, and my car is doing the same thing, and i already had the fuel pump replaced and the fuel injectors. I am gonna go and replace the DPFE myself this weekend, maybe today, and see if that helps. I will let you know if it does the trick
 
1 - 5 of 5 Posts
Top