Ford Focus Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
1,198 Posts
Discussion Starter #1
I got my clutch and light weight flywheel installed, and got all the bugs worked out, but I was curious if anyone with a lightweight flywheel was having the same problems. When i take off from a start, the car shudders like its bogging, but im at nearly 1200 rpms when it happens. ONLY happens from a complete stop when im taking off in first, and other than that, the clutch and fly feel amazing. I was curious if this is a common problem because of the flywheel, or if anyone knows what the problem could be? Ive been trying to overcome the problem off launches but cant.
 

·
Registered
Joined
·
130 Posts
I would think that you are feeling what the Ford Engineers put the Dual-Mass Flywheel in to prevent. The 4 cylinder engines power pulses are pretty far apart at low rpm and you no longer have the heavy flywheel to smooth them out.

All machines are a compromise and the stock flywheel gives up some performance for smoothness.
 

·
Registered
Joined
·
582 Posts
I'm with RecoilRob on this one. I've driven one SVT with a LW flywheel, and I experienced the same effect. The lighter flywheel just doesn't have the inertia (and hence, momentum) to do the job smoothly.

I've also had a similar problem with my revised flywheel from Ford. It isn't that bad, but it is more noticeable. I'm guessing they must have changed its mass and/or spring rates for this to happen. Mine works fine above that point as well...
 

·
Registered
Joined
·
1,198 Posts
Discussion Starter #5
i have a lightened flywheel/clutch combo as well, i have no vibration at take off
i didnt think the Vibrations came from the LW fly, but iwas hopin that would be the answer from a few people. Its more of a Shudder when you take off, i replaced the TOB and slave cylinder, and the Clutch feels amazing everywhere but the take off. is there anything i can get aligned to prevent this?
 

·
Registered
Joined
·
582 Posts
i have a lightened flywheel/clutch combo as well, i have no vibration at take off
i didnt think the Vibrations came from the LW fly, but iwas hopin that would be the answer from a few people. Its more of a Shudder when you take off, i replaced the TOB and slave cylinder, and the Clutch feels amazing everywhere but the take off. is there anything i can get aligned to prevent this?
You probably described it right the second time: a shudder. That describes more what I was talking about. What kind of clutch are you using? Sometimes certain clutches can be grabby at really low engine speeds and a lightened flywheel can exacerbate the problem. Have you tried different launch techniques? I've found that most cars with lightened flywheels need to be revved a touch higher at idle to get moving and the clutch needs to be feathered a bit more...its just the nature of the beast.
 

·
Registered
Joined
·
1,198 Posts
Discussion Starter #7
stage 3 clutchmaster. The only way i can prevent the shudder is lifting the clutch pedal up REAL fast with some gas, making it almost like a racing launch. Also, if i just roll through a stop a 1 or 2 mph and engage the clutch again, it doesnt do it, only when the cars weight actually needs to get started rolling...
 

·
Registered
Joined
·
2,247 Posts
It sounds like you are almost stalling the engine. You removed a lot of potential energy when you went to the lighter flywheel. It still takes the same amount of energy to get the car moving as before the light FW. So you need to increase the potential energy at the FW to launch. In other words give it more gas.
 
Joined
·
1,365 Posts
I am having a quaife, Fidanza FW, and clutchmasters stage 3 installed right now. I should have it back by this weekend and I'll let you know how it turns out. I personally found that you have to let off the gas quick even with the stock flywheel.
 

·
Registered
Joined
·
133 Posts
I would go with the clutch being "grabby" as well
. There isn't near as much middle ground on the stage 3 when it comes to engaged or not engaged. It's closer to off and on
 

·
Registered
Joined
·
1,198 Posts
Discussion Starter #11
I just hit 600 miles on the clutch, so now im starting to drive it normal, this shudder Also happens when i downshift and the RPMs hit around 1200 or so....
 

·
Registered
Joined
·
275 Posts
Isn't stage 3 a bit much for an svt focus? Just wondering, seems like overkill.
 

·
Registered
Joined
·
1,366 Posts
a sticky clutch and such a light flywheel with a low horse power 4 cylinder ... sounds like a poorly chosen combination for your low horse power car . get some more power and that will feel much better
 

·
Registered
Joined
·
4,271 Posts
Isn't stage 3 a bit much for an svt focus? Just wondering, seems like overkill.
Funny, mine feels just fine, stage 4
 

·
Registered
Joined
·
1,198 Posts
Discussion Starter #16
a sticky clutch and such a light flywheel with a low horse power 4 cylinder ... sounds like a poorly chosen combination for your low horse power car . get some more power and that will feel much better
Ive got a turbo kit i built by myself(put a few pics up awhile ago in the FI forum). I have just been waiting for the clutch to break in, then its going on. Hopefully in the next week or two i can start that install. I was just hoping this clutch thing wasnt anything serious before moving on
 
1 - 16 of 16 Posts
Top