Ford Focus Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
883 Posts
Discussion Starter #1
We had a nice, large thunderstorm here yesterday along with a 48 hour blackout. My AEM CAI went through 3 or 4 deep puddles and stalled each time. When I started it back up each time it squeaked and idle was at 900. Got the car home and let it sit overnight. Tonight when I punch it anything above 4500 the car wants no part of. It's like the ECU is cutting off fuel like when you hit the rev limiter only at 5k. Do I need to let it just dry for a few days before it runs normal or have I just f'd myself?
 

·
Registered
Joined
·
1,955 Posts
We had a nice, large thunderstorm here yesterday along with a 48 hour blackout. My AEM CAI went through 3 or 4 deep puddles and stalled each time. When I started it back up each time it squeaked and idle was at 900. Got the car home and let it sit overnight. Tonight when I punch it anything above 4500 the car wants no part of. It's like the ECU is cutting off fuel like when you hit the rev limiter only at 5k. Do I need to let it just dry for a few days before it runs normal or have I just f'd myself?
Ouch. OUCH. I don't know what to tell you, but when it rained like crazy in Troy last week, I was driving like a lunatic to avoid puddles... one section of John R had WAKE. Fortunately, I cut the wheel into the mall to avoid that. I'm not sure what to tell you, I've never actually gone through a puddle anywhere near that deep. I've had a couple friends lose cars doing that kind of thing, but their's wouldn't run at all after the stalls.
 

·
Registered
Joined
·
2,035 Posts
check the filter. If it is acting "clogged" because it is soaked, then it isn't getting the air the car needs. So that would be your problem. Check it and I would even replace it so you can atleast drive.
 

·
Registered
Joined
·
883 Posts
Discussion Starter #4
Car runs fine last few days. Not sure if it's 100% but defintely close.
 

·
Registered
Joined
·
2,782 Posts
I would recomend taking the filter off and cleaning it thoughouly, then re oil it. My guess is after being that wet a lot of the oil was diluted. When my cai is on I clean and re oil the filter every couple of weeks.
 
1 - 5 of 5 Posts
Top