Ford Focus Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
153 Posts
Discussion Starter #1 (Edited)
As the thread states. I have been having a really strong gas smell at the rear of the wife's 2002 ZX-5. I already dropped the tank and didn't find any leaks. I also replaced the Smog canister, the return hose that goes over the tank and the 5/8" fuel hose that goes to the check valve mounted at the top of the body by gas tank.

When filling the tank, I never go pass the auto shut off {old habit}, I started off with the simple replacement such as the gas cap.

Any help would be greatly appreciated as I am stuck on to what is causing this issue.

Just saw a write up that my problem could also be the Emission Check Valve Located in the Engine Bay. Is there any way to check this part, should it have 12V all the time when the engine is running?

PS NO CEL,

Thanks in advance,

Allcruisen
 

·
Registered
Joined
·
105 Posts
As the thread states. I have been having a really strong gas smell at the rear of the wife's 2002 ZX-5. I already dropped the tank and didn't find any leaks. I also replaced the Smog canister, the return hose that goes over the tank and the 5/8" fuel hose that goes to the check valve mounted at the top of the body by gas tank.

When filling the tank, I never go pass the auto shut off {old habit}, I started off with the simple replacement such as the gas cap.

Any help would be greatly appreciated as I am stuck on to what is causing this issue.

Just saw a write up that my problem could also be the Emission Check Valve Located in the Engine Bay. Is there any way to check this part, should it have 12V all the time when the engine is running?

PS NO CEL,

Thanks in advance,

Allcruisen
Not likely anything under the hood if the gas smell is in the rear. My bet is the tank vapor box that is mounted to the rear sub-frame. Hoses there can rot through or something has cracked.
 
1 - 2 of 2 Posts
Top