Ford Focus Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
Hello all, just ordered the 65mm throttle body for my 2003 SVTF from New Edge Performance. Just wondering if anybody had any problems with the install or any advice on the install. ALso do you have to manually set the idle with the screw or does the computer take care of that. I am also planning on keeping the stock air box which has a KN drop in filter for now until I can get the Focus-Sport unit. As far as I can see removing the stock throttle body looks pretty easy and accessible. Thanks for any input.

Wayne
 

·
Registered
Joined
·
2,782 Posts
Some one posted on this before. But, be sure and switch the gasket from the old tb to your new one. Be sure and give us your thoughts on the difference after the install. Any chance you could do a before and after dyno? Pleeeeeeeeease.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #3
Yes, I will definitely give some feedback on the throttle-body install, not too sure if there is a dyno near me though.

Wayne
 

·
Registered
Joined
·
426 Posts
I did mine today. It is pretty easy. The hardest part is getting the intake hose to fit over the bigger throttle body. You will probably need to use a new hose clamp for it.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #6
Just received the throttle-body today, any ideas on how to get the factory hose clamps off? There is absolutely no directions shipped with this part either.

Wayne
 

·
Registered
Joined
·
1,859 Posts
Do you see the small, raised holes in the clamp? Take a flathead scredriver and use it to twist them apart. Should pop right off.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #8
Yup, worked like a charm, thank-you. I finished the install, car runs and idles better than before. Now I gotta run to home depot to get some 3" hose clamps to hold the intake hose down.

Wayne
 

·
Registered
Joined
·
81 Posts
Call me ignorant
if you must, but how does this affect the warranty?
 

·
Registered
Joined
·
2,035 Posts
it shouldn't unless something breaks and the t-body caused it. But I am sure ford will figure out a way to blame the t-body for something.
 

·
Registered
Joined
·
45 Posts
Discussion Starter #11
As far as I know there should be no problem with the warranty on the vehicle. I guess I could call SVT and double check with them just in case. I like the new TB though, seems to rev much faster now and does not stumble when I coast to a stop in neutral as the stock one liked to do. Only thing that will take some getting used to is that the gas pedal requires more pressure to move, maybe its just cause its still new, anybody else experience that? Also one final question, what did you use to clamp the hose to the TB with? The stock one on the top of the air box fit fine but the bottom is too big to use the stock clamp, seems to fit tight enough not to use one, but i'd like to be safe.
 

·
Registered
Joined
·
426 Posts
I just used a different hose clamp.

The pedal is a bit stiffer but I think that is because the spring is stiffer. Overall I like it. I think there is better overall power and response.

The TB should really have been optimized from the factory if you ask me though. Screws should be counter sunk and edge should be smoother. I can do that later though.

My rpms hung up a bit at first when coming to a stop in neutral but that all sorted it self out after I had my battery disconnected for a good while when I was putting in my mach HID lights. That and the computer must have adjusted to it.

I will say that the stock TB looks like a piece of poop when you take it out.
 
1 - 12 of 12 Posts
Top