Ford Focus Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I need help! I have a 2004 zx3 and I have a TPS engine code and I have tried everything to get the damn code turned off! The problem is that my car tends to stay at 3-4k rpm when I go to shift and revs when I have my clutch in. (so the idle doesn't return to where it should be at when I have the clutch in).I have checked and replaced the TPS sensor and also cleaned it. I have tried to clean the idol air control valve and it didn't help me. I also cleaned the throttle body blade with no positive results. I don't have anywhere else to turn unless anyone has any ideas! Anything helps I really don't want to bring it to ford and pay 400 bucks. thanks for your input.

jake
 

·
Bacne..
Joined
·
2,690 Posts
I need help! I have a 2004 zx3 and I have a TPS engine code and I have tried everything to get the damn code turned off! The problem is that my car tends to stay at 3-4k rpm when I go to shift and revs when I have my clutch in. (so the idle doesn't return to where it should be at when I have the clutch in).I have checked and replaced the TPS sensor and also cleaned it. I have tried to clean the idol air control valve and it didn't help me. I also cleaned the throttle body blade with no positive results. I don't have anywhere else to turn unless anyone has any ideas! Anything helps I really don't want to bring it to ford and pay 400 bucks. thanks for your input.

jake

That implies you have a car with an automatic transmission.
The manual transmission TPS can work on an auto, but it does require a little work. I won't go into how this can be done as it may not work correctly. But I'd suggest you search for an answer on that topic.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
its a 5 speed. and I got the TPS from napa I think. but they showed me the pictures between the 2 and I defiantly have the automatic one in my manual car. it could be an early or late build time I was thinking. but I do know for sure that it was working for the whole time I owned the car. I started having a problem with the EGR valve and got that tightened back because it came loose on the header. and then it started spitting a TPS code at me so I'm a bit lost.
 
1 - 8 of 8 Posts
Top