Ford Focus Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter #1
I just updated the new YRF0 a few days ago.....I thought it would solve the problems like the battery light on and something else.....but after the update, the battery light came on at least twice.....does it happen to you guys too or just my car??

Ed
 

·
Registered
Joined
·
31 Posts
I've noticed that the battery light still comes on, but only when the RPM drops below 750... Like if you're taching 4k under load and just kick it in neutral and coast, the RPM's will fall below idle, and the battery light will come on. By the way, anyone else notice that the Odometer only flickers when your foot is on the brake?
 

·
Registered
Joined
·
286 Posts
I'm also getting idle dip with YRF0. I never had it with RLA2. It's been eratic. Yesterday, it stalled three times. Today, it was fine. I also have a stumble below 2K rpm when warm. Unless things improve, YRF0 will not be my friend.
~Dave
 

·
Registered
Joined
·
2,782 Posts
Wow, thats strange guys. I have had the new program for a few weeks, and have not had one hitch. Sorry to hear that. Might want to go ahead and call SVT and let them know about your problems.
 

·
Registered
Joined
·
57 Posts
Discussion Starter #6
What should I do to reprogram the ecu?
 

·
Registered
Joined
·
151 Posts
Did you do the reprogramming thing it says in the manual?? My dealer didn't do it...after I did it--everything was perfect.
Not sure what your talking about,,,like to help us out? Like page in manual? Or mabye how to do it? Are you talking about some sorta steps to take after the ECU is reflashed? Thanks.
 

·
Registered
Joined
·
286 Posts
I think he's refering to the procedure used when replacing/disconnecting the battery. The ECU needs to "relearn" the idle. The manual instructs you to shut off all accessories, start the car, and let it idle for at least one minute. If this is not followed(like driving the car right away), it will take more time to relearn the idle while driving.

This may have been what happened to mine. I thought I let it idle for at least a minute, maybe not. It is getting better now. I have no other explanation.

Anybody else?
~Dave
 

·
Registered
Joined
·
9 Posts
ok guys....its on page 175 in the 2003 Ford Focus Owners Guide...not the SVT supplement. The steps are as follows:

1.With the vehicle at a complete stop, set parking brake.

2.Put the gear shift in Neutral postition and turn off ALL accessories and start engine.

3.RUN ENGINE UNTIL IT REACHES NORMAL OPERATING TEMPATURE (VERY IMPORTANT)

4.Allow the engine to idle for at least one minute.

5.Turn the A/C on and allow the engine to idle for at least one minute (ALSO VERY IMPORTANT)

6.Drive the car to complete the relearning process

*The vehicle may need to be driven 10 miles or more to relearn the idle and fuel trim.


I followed these steps and then my car ran like a normal car, before I did this my car was idle at 2000 plus and surging even after the reflash. Now I love the thing..
 

·
Registered
Joined
·
286 Posts
Interesting. This is quite a bit different from the 2002 procedure I reviewed above. No wonder mine took so long!

Thanks for posting the new version, yeti.
~Dave
 
1 - 11 of 11 Posts
Top