Ford Focus Forum banner

1 - 20 of 29 Posts

·
Registered
Joined
·
2,333 Posts
Discussion Starter #1
Ok everybody I installed the Venom400 Performance Module, and let me tell you ddiizzaaaammmmm!! what a difference!! The response Im getting in combination with the FC TB is awsome! I had some low end power taken away from me after my Crower Cams were installed. The Venom400 deffintly got me this power back. My take off is really quick now and I have power both low and and up top. I actually noticed the power more up top. The first drive with it I bounced right off the limiter as I never saw my car rev the fast! Also it got rid of the problems I was having with my FC TB(idle climbing and jumping at a stop). To anybody who said this is a waste of money, WRONG! I am going to dyno my car again with the addition of this module just to see exatly what it did if anything. Says Dyno Proven on the front cover, we'll see
 

·
Registered
Joined
·
477 Posts
I'm glad to see you like it. I have been enjoying mine now for close to a year. Looking forward to your dyno results for the 400.
 

·
Registered
Joined
·
2,333 Posts
Discussion Starter #3
wow, one year..any problems with yours yet? and did you get it dynoed? Isnt the cool little red flashing light the coolest!!
 

·
Registered
Joined
·
477 Posts
I think the Venom400 was a contributing factor in the Cat burning out. But other than that no probs. Have not had it dyno'ed due to living in a sh***y little town with no access to one.

Where did you put you L.E.D? I put mine down by my left leg where I know where its at but not noticeable to others. I just used the fuse pane cover as a holder for it.

Hopefully you didn't use those little wire taps they sent because they suck. If you did, take them off, strip the factory wire and solder the Venom wires in. Solid connection. I noticed that mine was not responding right after two runs with the Venom400. I noticed on one run that the car would run like a scalded dog and the next run it just didn't run very well. So I removed the splices and soldered the wires in and got great responses. I just think your not getting a great connection with the splices.
 

·
Registered
Joined
·
2,333 Posts
Discussion Starter #7
<blockquote><font size="1" face="Verdana, Arial">quote:</font><hr>Originally posted by TCR Motorsports:
I think the Venom400 was a contributing factor in the Cat burning out. But other than that no probs. Have not had it dyno'ed due to living in a sh***y little town with no access to one.

Where did you put you L.E.D? I put mine down by my left leg where I know where its at but not noticeable to others. I just used the fuse pane cover as a holder for it.

Hopefully you didn't use those little wire taps they sent because they suck. If you did, take them off, strip the factory wire and solder the Venom wires in. Solid connection. I noticed that mine was not responding right after two runs with the Venom400. I noticed on one run that the car would run like a scalded dog and the next run it just didn't run very well. So I removed the splices and soldered the wires in and got great responses. I just think your not getting a great connection with the splices.
<hr></blockquote>

I moounted the LED light so it pops out of the dash under one of the vents..thanks for the tip on soldering the wires I just may have to do that now
thanks again
 

·
Registered
Joined
·
521 Posts
what does the led show you?
 

·
Registered
Joined
·
2,333 Posts
Discussion Starter #9
<blockquote><font size="1" face="Verdana, Arial">quote:</font><hr>Originally posted by twilightblue:
what does the led show you?<hr></blockquote>

It shows when the Venom is activated..it comes on only when you floor it which is damn good to save some gas!!
 

·
Registered
Joined
·
2,333 Posts
Discussion Starter #11
Yes there is a switch directly on the module to turn it on or off as you please..say for instance your traveling far and want to save some gas then turn that puppy off..No it doesnt work like a superchip or diablo..It connects to your postive/negative battery term..one wire from the MAF and one wire from the TPS..very easy to install..you can also still use a diablo or superchip in conjunction with this!! I liked that!I snagged this up for $120, but I think they go for like $350 or sumthin..check out the website I listed above for more details..awsome little gadget though
 

·
Registered
Joined
·
254 Posts
damn, you got a really good deal on it. i'm thinking about getting it for $270. do you have a chip as well as the venom 400? if so, how good do they work in conjunction with each other?
 

·
Registered
Joined
·
2,333 Posts
Discussion Starter #14
<blockquote><font size="1" face="Verdana, Arial">quote:</font><hr>Originally posted by f242:
glad that you like it Vince.
<hr></blockquote>

thanx for the excellent deal Marc!! now sell me your pectel...
 

·
Registered
Joined
·
2,333 Posts
Discussion Starter #15
<blockquote><font size="1" face="Verdana, Arial">quote:</font><hr>Originally posted by ztsfocus:
damn, you got a really good deal on it. i'm thinking about getting it for $270. do you have a chip as well as the venom 400? if so, how good do they work in conjunction with each other?<hr></blockquote>

Heck yea I would get it

No Im not running a chip with it yet, but I know another fellow member from so cal(S on Da 5) had the Venom400 with a superchip and liked it very much..
 

·
Registered
Joined
·
258 Posts
never ceases to amaze me that the eram is considered junk, but the venom 400 is a quality upgrade.

want the same results the venom gives, without spending any money? step on the gas harder, or tie a weight to your right foot.

Russ
 

·
Registered
Joined
·
5,333 Posts
<blockquote><font size="1" face="Verdana, Arial">quote:</font><hr>Originally posted by FordEscortLX:
never ceases to amaze me that the eram is considered junk, but the venom 400 is a quality upgrade.

want the same results the venom gives, without spending any money? step on the gas harder, or tie a weight to your right foot.

Russ
<hr></blockquote>


What is eram?
 

·
Registered
Joined
·
101 Posts
eram=to little power for to much $$$
 

·
Registered
Joined
·
205 Posts
One dumb question,

How can a WOT voltage equivalence be sent down the MAF ouput lead, while the TB is only partialy open?

.02
 
1 - 20 of 29 Posts
Top