Ford Focus Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
578 Posts
Discussion Starter #1
I am attempting to install the Volant and Pro Form MAF on my Focus. The Volant is set up to accept the Ford MAF which has the mounting flange built in.

The Pro Form MAF does not have this flange. How are those of you with this system doing the install?

Thanks.
 

·
Registered
Joined
·
5,580 Posts
contact ray or bobby at mcnews, i believe they have an adapter bracket they've constructed 2 put the pro flow MAF right up 2 the volant intake. i have seen them install it on a customer car, and i believe they have or could make more.

-Ult
 

·
Registered
Joined
·
400 Posts
No need for a bracket. We just did this setup on my car. Use the same bolts you had the old MAFS on with, but add a bigger washer. With the washers on the lip of the MAFS it stays on tight.

Good luck on the Pro-M. I've had two installed now and had nasty problems with both...still working on getting it sorted out....
 

·
Registered
Joined
·
578 Posts
Discussion Starter #7
Hmmm - nasty problems?


What type of problems are you having? If you are now on all units you tried, what motivates you to keep trying? Does is seem like something that could be solved?
 

·
Registered
Joined
·
1,429 Posts
I have the same setup-it's not a big deal to hook it up to the Volant. I used screws and silicone to seal it with no problems in over a year. I haven't had any problems with my recalibrated MAFS-works great. Did you get yours calibrated to your specific engine mods?
 

·
Registered
Joined
·
400 Posts
I've tried two so far with normal calibration, and both have sputtered and given me idle troubles and stalls. Got another coming from FC (who has been GREAT help and easy to work with, BTW) tomorrow, I'll slap it on and let you guys know....
 

·
Registered
Joined
·
578 Posts
Discussion Starter #10
Originally posted by nordy200:
I have the same setup-it's not a big deal to hook it up to the Volant. I used screws and silicone to seal it with no problems in over a year. I haven't had any problems with my recalibrated MAFS-works great. Did you get yours calibrated to your specific engine mods?
<font size="2" face="Verdana, Arial">Yes, I bought mine through FC as well and it is calibrated for the Focus. I'm running the stock injectors as I'm running NA with cams on the mild side.
 

·
Registered
Joined
·
578 Posts
Discussion Starter #11
Originally posted by SuperMatt:
I've tried two so far with normal calibration, and both have sputtered and given me idle troubles and stalls. Got another coming from FC (who has been GREAT help and easy to work with, BTW) tomorrow, I'll slap it on and let you guys know....
<font size="2" face="Verdana, Arial">I bought mine through FC at the same time I purchased the cylinder heads, cams, etc. Plus Nadar knew all my other mods as I did send him the list. One can assume the calibration was done with this knowledge in hand. I'm at the point where I just want the car to get up and run! So I'd like this last step to go smoothly.
 
1 - 11 of 11 Posts
Top