Ford Focus Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
299 Posts
Discussion Starter #1
What the trick for removing the water pump? I've removed all the fasteners and pulled it out but it's trapped between the engine and the unibody. I can't see by removing anything else that this would help. This can't be that hard......
 

·
Registered
Joined
·
733 Posts
Hey Walter did you figure out the buzzing/ticking noise??
it was your water pump??
try asking norsol in the tech area he should know how to remove the pump..
 

·
Registered
Joined
·
299 Posts
Discussion Starter #3
That's what that ticking noise was. I wasn't the water pump itself but one of the 3 fasteners had backed out and the accessory wheel was wobbling on the water pump shaft. I didn't figure it out until the second fastener had backed out.
And I've never touched the water pump. Everyone should check their fasteners......
 

·
Registered
Joined
·
733 Posts
Hey excellent at least it was nothing too catastrophic..

sometimes its the simple things we overlook....
 

·
Registered
Joined
·
365 Posts
Hey did it start leaking at all? Mine just started leaking last week, i think it is the water pump cause i dont see it leaking from any hose, any suggestions would be of great help.
Ryan
 

·
Registered
Joined
·
136 Posts
remove the three bolts holding the pully on, then remove pulley. Waterpump will now clear.
 

·
Registered
Joined
·
299 Posts
Discussion Starter #7
The pulley was removed to begin with and the water pump is still trapped. Before my other thread was locked, there was a post suggesting that the RH engine mount had to be removed. I'm thinking now that might be what it takes.
My water pump never leaked. What happened with the fasteners that held the pulley on backed out. In doing so they created a wobble between the pump and the pulley and buggered up threads on the water pump so now they won't hold the pulley on any longer without backing out again. This has happened twice now.
 

·
Registered
Joined
·
136 Posts
Hmmm... I did have the motor mount out at the time. I was replacing the timing belt and water pump at the same time.
 
1 - 8 of 8 Posts
Top