Ford Focus Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2,333 Posts
Discussion Starter #1
Well maybe this has been gone over before, but in case not here we go..ok so I had a CEL on that was caused from the FS Race Header and not having a cat.. So today I hop in my car and the CEL is not there anymore! wtf?? I mean its good...but IM just curious. Is the car burning so clean that is sensing good air now that not even a cat is needed in the car?
 

·
Registered
Joined
·
7,351 Posts
It will come back. Not to worry.


Back when my O2 went it went off and came back on a couple times.
 

·
Registered
Joined
·
2,333 Posts
Discussion Starter #4
damn I thought i was lucky..
 

·
Registered
Joined
·
2,333 Posts
Discussion Starter #5
still hasnt came back...
 

·
Registered
Joined
·
1,429 Posts
it probably will come back. When I had the Esslinger intake cam on my ZX 3 the CEL would come on and off in an irregular pattern, a few days, a week or so. The car ran great at higher rpm's but had idle issues due to valve overlapping.
 

·
Registered
Joined
·
601 Posts
When the check engine light goes on and off every few days it is a sign that the first O2 sensor is bad. The car will be very hesistant on warm up. It will studder back and forth. If this is your case then the first O2 sensor is bad.

Eric
 

·
Registered
Joined
·
358 Posts
just a thought but doesn't the FS race header eliminate the first cat and o2 sensor? If so you can check out New Edge Proformance they have an o2 cheater harness that is suposse to fix that problem I think.
 

·
Registered
Joined
·
105 Posts
When I had a focus and gutted the cat, the light didn't come on for about 2 weeks...
 
1 - 9 of 9 Posts
Top